Skip to content
October 12, 2006 / jadettman

The Lappy Returns!

I’ve been having trouble with my laptop for quite a while. For some reason, it would make this really loud noise when I turned it on and it just wouldn’t keep accurate time when it was unplugged.

A computer-wise friend told me that the noise was likely an indicator that the CMOS chip was bad. So, a few months ago (after the Wisconsin move), I took the laptop to CompUSA because that was where the original owner purchased the thing. Also, it had a service plan, so the fixing was free! 🙂

Unfortunately, the fixing was time-consuming. I first took the laptop to the Madison store and they had it for about three weeks, but they didn’t fix it. Then I took it to the Rockford store because it was closer than Madison. They had it for two weeks but when I went to pick it up is still wasn’t fixed. So they kept it for two more weeks.

So, finally, when I went back for the third time they had it fixed. It turns out they don’t test laptops with them unplugged, you know, because why would anyone ever unplug a laptop. It’s not like you’d want to go some where with it.

Advertisements

2 Comments

Leave a Comment
  1. Dan / Oct 13 2006 10:59 pm

    Sounds like they’re super-duper qualified type technicians. Yessirree.

  2. J.A. Dettman / Oct 14 2006 8:51 am

    Well, you know, they do have to send the equipment to the super-duper qualified technician center whenever you have to get something fixed. So you know it must be good!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

%d bloggers like this: